The Problem with Visual Composer for WordPress 4.5

Using WordPress 4.5 in combination with outdated versions of the Visual Composer plugins can produce some serious bugs, including losing access to your WP-Admin section, Tab elements, etc…

If you have switched to WordPress 4.5, we highly recommend you update your plugins and themes.

Update theme.

Follow the steps below to manually update the theme:

  1. Backup your website completely to make sure you have restore point in case of any complications.
  2. First, you download the new theme package from themeforest. You have to log into your themeforest account and navigate to Downloads tab. You find the theme in your purchased themes list
  3. You can delete the current theme. Don’t worry about this. Your data won’t be lost.
  4. You upload the new theme package via WordPress or FTP software.

NOTE: Updating this theme will lose any customization you have made

Please ensure that you only upload the installable wordpress file. If not, you may get an error message: The package could not be installed. The theme is missing the style.css stylesheet.

Update the plugins:

Update the Visual composer plugin:
Follow the steps bellow to manually update the Visual composer plugin:

  1. Open the updated theme files from Themeforest that you have downloaded. Open the zip file from them. Visual composer 4.11.x plugin is available in this path: /theme-package-downloaded/includes/plugins/js_composer.zip
  2. Extract the js_composer.zip
  3. With your FTP program, upload the extracted folder to the wp-content/plugins folder in your WordPress directory online. NOTE: Make sure you overwrite the existing plugins-files
  4. Visual composer has been updated!

Update the Lee Framework plugin: (Only for Bleu theme)
Follow the steps bellow to manually update the Lee Framework plugin:

  1. Open the updated theme files from Themeforest that you have downloaded. Open the zip file from them. Lee Framework plugin is available in this path: /theme-package-downloaded/includes/plugins/lee_framework.zip.
  2. Extract the lee_framework.zip
  3. With your FTP program, upload the extracted folder to the wp-content/plugins folder in your WordPress directory online. NOTE: Make sure you overwrite the existing plugins-files
  4. Lee Framework has been updated!

Fix some elements when the update finished.

There are some elements deprecated after you updated to Visual composer 4.11.x. Ex: Tab element

Follow the steps bellow to fix Tab element:
Navigate Dashboard > Pages > Open the page that have the Tab element.
Delete the old Tab element and Insert a new Tab element again.

That’s all folks!
Good luck making your updates work!

2 Comments